10/25/2017

nopCommerce 3.90 - Related Problem



Add Entity Migrations


Reference Data :
https://www.pronopcommerce.com/using-entity-framework-ef-code-first-migrations-in-nopcommerce-for-fast-customizations

Steps:
  1. Install nopCommerce
  2. Enabled-Migrations.  If you get error messages when you try to enable migration, update all Entity Frameworks to varsion 6.1.2.  Then, enable the migration again.
  3. add-migration InitialMigration -IgnoreChanges

Build nopCommerce in Release configuration, some packages are not valid.


Reference Data :
https://www.nopcommerce.com/boards/t/32421/solution-build-error-rebuild-solution-failed-in-release-mode-340.aspx

Change Slide Picture

Reference Data:
https://www.nopcommerce.com/boards/t/38721/changing-the-slideshow-images-on-the-homepage.aspx

Log4Net

https://sadi02.wordpress.com/2008/09/15/how-to-store-log-in-database-using-log4net/

How to subscribe to an event in a plugin?

https://www.nopcommerce.com/boards/t/12719/how-to-subscribe-to-an-event-in-a-plugin.aspx

Creating a custom task. V3.0 or later

https://www.nopcommerce.com/boards/t/28253/creating-a-custom-task-v30-or-later.aspx

10/23/2017

Integrate .Net Object into Talend


Related link: http://talendforge.org/wiki/doku.php?id=doc:dotnet

1. Remember to download janet-win and follow the instruction to install the dll.
2. Talend .Net component can only load DLL, cannot load EXE.

8/17/2017

nopCommerce - Publishing Issues - Could not load file or assembly


Solution:
  1. Install PowerShell 3.0 or above
  2. In PowerShelll dir "C:\root_source_directory" -Recurse | Unblock-File
Related Information:
  1. Get PowerShell: https://github.com/powershell/powershell#get-powershell
  2.  Original reference page: https://www.nopcommerce.com/boards/t/38178/publishing-issues-could-not-load-file-or-assembly.aspx

1/09/2017

.Net Send Email Problem - net_io_connectionclosed

最近在 migrate 舊的 .net 程式到 Windows Server 上, 其中有一個 SMTP 的 Setting 造成 Email Send 不出去, 得到下列的 Error Message.

System.Net.Mail.SmtpException: net_io_connectionclosed

Program 是 .Net 2.0, Server 是 Windows

Server 2008 在這篇文章中找到 Solution.

I ran into this today and the solution is tied somehow to the IP addresses you are using to secure the SMTP virtual server.  My server has multiple IP addresses bound to the same adapter and the VS was configured to use one of them.  However, I had all of the access restrictions to allow connections only from 127.0.0.1 which is the source of the error (I believe.

So, whatever the IP address your VS is listening on OR the IP your application is configured to use, configure the following areas:
  • Access/Connection control/Only the list below/[add your server ip]
  • Access/Relay restrictions/Only the list below/[add your server ip]
  • Configure your application to utilized the server ip, not localhost or 127.0.0.1